Co-Sell AWS - Users are unable to submit or accept co-sell opportunities

Incident Report for Tackle.io

Resolved

We have confirmed submissions. This incident is now resolved.
Posted Oct 16, 2025 - 15:31 MDT

Monitoring

AWS has informed us that a fix has been implemented. We are monitoring our systems to confirm Co-sells are able to be submitted and accepted.
Posted Oct 16, 2025 - 15:24 MDT

Identified

AWS is aware of the issue and aware of the limit. They are working on adjusting this limit. We will provide an update in 30 minutes.
Posted Oct 16, 2025 - 14:55 MDT

Update

Users are unable to submit or accept AWS co-sell opportunities. We have escalated this incident with our partners at AWS Marketplace.
Posted Oct 16, 2025 - 13:50 MDT

Investigating

We are currently investigating this issue.
Posted Oct 16, 2025 - 13:09 MDT
This incident affected: Co-Sell.