This incident is resolved. All delayed messages have been processed and sent.
Posted Aug 19, 2024 - 15:42 MDT
Update
Delayed emails are slowly processing. We continue to monitor the system.
Posted Aug 19, 2024 - 14:52 MDT
Monitoring
We are currently experiencing issues with a third-party notification service resulting in delays with emails. Some users may not receive notifications in a timely manner. The third-party notification service has implemented a fix and we are monitoring the results.
Posted Aug 19, 2024 - 13:55 MDT
This incident affected: Order processing & notifications.