We have deployed a fix and are currently monitoring the AWS Co-sell System.
Posted Apr 21, 2025 - 15:00 MDT
Update
We believe have identified the issue and are verifying a fix.
Posted Apr 21, 2025 - 14:51 MDT
Identified
There is currently an outage in the new AWS Co-sell experience. The Co-sell List view is not showing AWS Co-sell Opportunities, same with viewing Co-sells from Tackle for Salesforce 2.0. AWS Co-sell creation continues to work as expected.