Microsoft Offers not available in Tackle for Salesforce for new private offer creation

Incident Report for Tackle.io

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 17:23 MST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 17, 2025 - 16:23 MST

Investigating

In Tackle for Salesforce, Microsoft is not showing as an option for private offer creation. We are currently investigating the issue.
Posted Nov 17, 2025 - 15:33 MST
This incident affected: Offers / Marketplace Creation.