Unable to update and submit approved AWS co-sell opportunities

Incident Report for Tackle.io

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 05:23 MDT

Monitoring

The issue has been resolved, and we are monitoring the issue.
Posted Mar 31, 2026 - 15:30 MDT

Investigating

We are currently investigating this issue.
Posted Mar 31, 2026 - 15:02 MDT
This incident affected: Co-Sell.