We are continuing to experience delays in the creation of private offers within the AWS marketplace. This is a result of the AWS us-east-1 outage reported. AWS has applied mitigations and the recovery process is underway. Tackle is actively tracking the affected offers along with other activities and will update the status as AWS progresses toward recovery.
Posted Oct 20, 2025 - 14:32 MDT
Monitoring
AWS has implemented a fix and we are monitoring our systems.
Posted Oct 20, 2025 - 04:25 MDT
This incident affected: Offers / Marketplace Creation.